summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLouis-Francis Ratté-Boulianne <lfrb@collabora.com>2018-02-28 01:19:37 +0000
committerAdam Jackson <ajax@redhat.com>2018-03-05 13:27:34 -0500
commit4023d537341b9c36b9bb248c206e40694e4b08d2 (patch)
treebb86a3602e4615d6498a6f42265049a2238ff7fc /configure.ac
parente2ef3b44fa697f2ed453767e98da72ea56d4046f (diff)
modesetting: Use atomic modesetting API for pageflip if available
In order to flip between compressed and uncompressed buffers - something drmModePageFlip explicitly bans us from doing - we need to port use the atomic modesetting API. It's only 'fake' atomic though given we still commit for each CRTC separately and CRTC and connector properties are not set with the atomic API. The helper functions to retrieve DRM properties have been borrowed from Weston. Signed-off-by: Louis-Francis Ratté-Boulianne <lfrb@collabora.com> Reviewed-by: Daniel Stone <daniels@collabora.com> Acked-by: Keith Packard <keithp@keithp.com> Reviewed-by: Adam Jackson <ajax@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e1ca8f974..00549148c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2101,6 +2101,9 @@ if test "x$GLAMOR" = xyes; then
fi
fi
+ PKG_CHECK_EXISTS(libdrm >= 2.4.62,
+ [AC_DEFINE(GLAMOR_HAS_DRM_ATOMIC, 1, [libdrm supports atomic API])],
+ [])
PKG_CHECK_EXISTS(libdrm >= 2.4.74,
[AC_DEFINE(GLAMOR_HAS_DRM_NAME_FROM_FD_2, 1, [Have GLAMOR_HAS_DRM_NAME_FROM_FD_2])],
[])