summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2014-04-09 15:24:21 -0700
committerChris Wilson <chris@chris-wilson.co.uk>2014-04-10 09:07:38 +0100
commita6919aa980883cf2828dc0cf813f315e3035d0cf (patch)
tree7dab5eeacea11439eedb6e43807c8146b57b1537 /configure.ac
parentbe7c166a017cee3ef8a1b7b290b7fb14b4009314 (diff)
Update for glamor in the 1.16 server.
We should link against the server's copy, insted of using the external library.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 75428989..0fdbc3c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -344,8 +344,10 @@ if test "x$GLAMOR" != "xno"; then
if test "x$UXA" != "xyes"; then
AC_MSG_ERROR([Glamor acceleration requested but UXA is not enabled])
fi
- PKG_CHECK_MODULES(LIBGLAMOR, [glamor >= 0.6.0])
- PKG_CHECK_MODULES(LIBGLAMOR_EGL, [glamor-egl])
+ if ! pkg-config --exists "xorg-server >= 1.15.99.901"; then
+ PKG_CHECK_MODULES(LIBGLAMOR, [glamor >= 0.6.0])
+ PKG_CHECK_MODULES(LIBGLAMOR_EGL, [glamor-egl])
+ fi
AC_DEFINE(USE_GLAMOR, 1, [Enable glamor acceleration])
fi