summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2014-05-09 11:08:15 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2014-06-02 08:32:11 +0100
commit6ab6734369fbd902a23109f4c3626df9d529891c (patch)
tree36dac823ac3fe0d9108bbd1e8575b450aae3f567 /configure.ac
parentd6240d197be1e752c0de26fbf84fc8fa8d55383c (diff)
Add rudimentary tests for DRI3
This is a simple little test to create a pixmap from a local bo, copy it to a normal pixmap, then read it back by importing it into anther local bo. It tests the fundamental mechanisms of opening a DRI3 render device, importing into pixmaps, exporting into /buffers and a read-barrier. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ec237c45..e89e5a38 100644
--- a/configure.ac
+++ b/configure.ac
@@ -239,6 +239,9 @@ if test "x$shm" = "xyes"; then
AC_MSG_RESULT(assuming no))
fi
+PKG_CHECK_MODULES(X11_DRI3, [xcb-dri3 xcb-sync x11-xcb xshmfence x11 xrender xext libdrm], [x11_dri3="yes"], [x11_dri3="no"])
+AM_CONDITIONAL(X11_DRI3, test "x$x11_dri3" = "xyes" -a "x$shm" = "xyes")
+
AC_ARG_ENABLE(tools,
AS_HELP_STRING([--disable-tools],
[Enable building and installing the miscellaneous tools [default=auto]]),