summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e23dc1df..97eeab82 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -44,6 +44,10 @@ if LIBUDEV
radeon_drv_la_LIBADD += $(LIBUDEV_LIBS)
endif
+if DRI3
+RADEON_DRI3_SOURCES = radeon_dri3.c radeon_sync.c
+endif
+
ati_drv_la_LTLIBRARIES = ati_drv.la
ati_drv_la_LDFLAGS = -module -avoid-version
ati_drv_ladir = @moduledir@/drivers
@@ -58,7 +62,8 @@ radeon_drv_la_SOURCES = \
radeon_misc.c radeon_probe.c \
radeon_textured_video.c radeon_xvmc.c \
$(RADEON_EXA_SOURCES) \
- $(RADEON_KMS_SRCS)
+ $(RADEON_KMS_SRCS) \
+ $(RADEON_DRI3_SOURCES)
if GLAMOR
AM_CFLAGS += @LIBGLAMOR_CFLAGS@