summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d817326..cac6de5 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,14 +1,22 @@
lib_LTLIBRARIES = libxshmfence.la
+if PTHREAD
+PTHREAD_SOURCES=xshmfence_pthread.c
+endif
+
+if FUTEX
FUTEX_SOURCES=xshmfence_futex.c
+endif
libxshmfence_la_SOURCES = \
xshmfence_alloc.c \
+ $(PTHREAD_SOURCES) \
$(FUTEX_SOURCES)
-noinst_HEADERS = xshmfence_futex.h xshmfenceint.h
+noinst_HEADERS = xshmfence_pthread.h xshmfence_futex.h xshmfenceint.h
libxshmfence_la_LDFLAGS = -version-number 1:0:0 -no-undefined
+libxshmfence_la_LIBADD = @PTHREAD_LIBS@
libxshmfenceincludedir = $(includedir)/X11
libxshmfenceinclude_HEADERS = xshmfence.h