summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLenny Komow <lenny@lunarg.com>2016-11-07 10:44:23 -0700
committerLenny Komow <lenny@lunarg.com>2016-11-08 09:07:28 -0700
commita5333eee2224a82765e669344437c50ea4f06a6e (patch)
treeeb4881bf9fc8fc5cbbbd409c754c7c5a6ff8cffc /CMakeLists.txt
parent041eb5d5809fb5397cbdfc2b59ddf10b1e58047e (diff)
build: Allow the use of a custom-named vulkan dll
Change-Id: Ibeae30386ca2a91717d6b4c3039ada884003a1a4
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4cd4d30d..8176116d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,9 +5,12 @@ cmake_minimum_required(VERSION 2.8.11)
project (VULKAN)
# set (CMAKE_VERBOSE_MAKEFILE 1)
+# The API_NAME allows renaming builds to avoid conflicts with installed SDKs
# The MAJOR number of the version we're building, used in naming
-# vulkan-<major>.dll (and other files).
+# <api-name>-<major>.dll (and other files).
+set(API_NAME "Vulkan" CACHE STRING "API name to use when building")
set(MAJOR "1")
+string(TOLOWER ${API_NAME} API_LOWERCASE)
find_package(PythonInterp 3 REQUIRED)