summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJon Turney <jon.turney@dronecode.org.uk>2017-06-17 14:32:30 +0100
committerJon Turney <jon.turney@dronecode.org.uk>2017-06-20 13:07:20 +0100
commitfb212f2c1bcfb015112aa665dd1f25d9b80f86fc (patch)
tree43d5392da6653ea9f6c0262d49aa460c326e2d39 /meson.build
parent6d2b7d33678e7a881ebdb5ceb4a32509ad3ee930 (diff)
meson: Make VBE and VGAHW modules optional
Don't build them on platforms where they aren't meaningful. Note that autoconf defines WITH_VGAHW when building the VGAHW module, but that doesn't seem to be used anywhere, so we just drop that. Signed-off-by: Jon Turney <jon.turney@dronecode.org.uk> Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build24
1 files changed, 22 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index f0b1ef0a2..79da23740 100644
--- a/meson.build
+++ b/meson.build
@@ -260,6 +260,28 @@ if libdrm_dep.found()
build_modesetting = libdrm_dep.version().version_compare('>= 2.4.46')
endif
+build_vbe = false
+if get_option('vbe') == 'auto'
+ if (host_machine.system() != 'darwin' and
+ host_machine.system() != 'windows' and
+ host_machine.system() != 'cygwin')
+ build_vbe = true
+ endif
+else
+ build_vbe = get_option('vbe') == 'yes'
+endif
+
+build_vgahw = false
+if get_option('vgahw') == 'auto'
+ if (host_machine.system() != 'darwin' and
+ host_machine.system() != 'windows' and
+ host_machine.system() != 'cygwin')
+ build_vgahw = true
+ endif
+else
+ build_vgahw = get_option('vgahw') == 'yes'
+endif
+
# XXX: Allow configuration of these.
build_apm = false
build_acpi = false
@@ -267,8 +289,6 @@ build_dpms = true
build_mitshm = true
build_res = true
build_screensaver = true
-build_vbe = true
-build_vgahw = true
build_xace = true
build_xsecurity = true
build_xf86bigfont = true