summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2011-03-04 12:47:00 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2011-03-04 12:47:00 +1000
commitd6fc5be2969b9eede3c0fdd6e03daec4100a8c9f (patch)
tree34c7615bead1a2a0df108064da23a0dd2b34d0f6 /configure.ac
parentde0dfb76444ad4160468d00515876c91a9fa20bf (diff)
parentcf451f34e3bdd52a4eb072ce9f4b514eb83a1cfc (diff)
Merge branch 'next'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 15 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index c057ffb..c3605f3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,21 +98,31 @@ AM_CONDITIONAL(DEBUG, [test "x$DEBUGGING" = xyes])
AC_MSG_CHECKING([which optional backends will be build])
case "${host}" in
*linux*)
- AC_MSG_RESULT([eventcomm])
+ AC_MSG_RESULT([ps2comm alpscomm eventcomm])
+ BUILD_PS2COMM="yes"
BUILD_EVENTCOMM="yes"
- AC_DEFINE(BUILD_EVENTCOMM, 1, [Optional backend eventcomm enabled])
;;
-*freebsd* | *openbsd* | *netbsd* | *dragonfly*)
- AC_MSG_RESULT([psmcomm])
+*freebsd* | *netbsd* | *dragonfly*)
+ AC_MSG_RESULT([ps2comm alpscomm psmcomm])
+ BUILD_PS2COMM="yes"
BUILD_PSMCOMM="yes"
- AC_DEFINE(BUILD_PSMCOMM, 1, [Optional backend psmcomm enabled])
;;
*)
AC_MSG_RESULT([none])
;;
esac
+if test "x$BUILD_EVENTCOMM" = xyes; then
+ AC_DEFINE(BUILD_EVENTCOMM, 1, [Optional backend eventcomm enabled])
+fi
+if test "x$BUILD_PSMCOMM" = xyes; then
+ AC_DEFINE(BUILD_PSMCOMM, 1, [Optional backend psmcomm enabled])
+fi
+if test "x$BUILD_PS2COMM" = xyes; then
+ AC_DEFINE(BUILD_PS2COMM, 1, [Optional backend ps2comm and alpscomm enabled])
+fi
AM_CONDITIONAL([BUILD_EVENTCOMM], [test "x${BUILD_EVENTCOMM}" = "xyes"])
AM_CONDITIONAL([BUILD_PSMCOMM], [test "x${BUILD_PSMCOMM}" = "xyes"])
+AM_CONDITIONAL([BUILD_PS2COMM], [test "x${BUILD_PS2COMM}" = "xyes"])
# -----------------------------------------------------------------------------
# Dependencies for synclient and syndaemon