summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2013-05-29 15:07:44 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2013-10-14 16:34:10 +1000
commit41840a656f5c790b49fe798b9d99136c23e09a5f (patch)
tree732577d37eef3e3a08f006db8b68cc2eec4ddc56 /configure.ac
parent0fb59b3487d57523a03f078a2061e2ea0cacbc7c (diff)
Switch to libevdev for the eventcomm backend
This has a potential bug that would need to be fixed in mtdev first: if we get a SYN_DROPPED and we miss out on events, the current code emulates a normal EV_SYN, feeds that to mtdev and hopes that that fills the mtdev output queue. If mtdev doesn't generate events on that EV_SYN, we're stuck in limbo and may get weird results. The loop will continue and sync the device, but there's the off chance we get odd events. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5dfbc4e..7986d31 100644
--- a/configure.ac
+++ b/configure.ac
@@ -120,6 +120,7 @@ if test "x$BUILD_EVENTCOMM" = xyes; then
# Obtain compiler/linker options for mtdev
PKG_CHECK_MODULES(MTDEV, mtdev)
+ PKG_CHECK_MODULES(LIBEVDEV, [libevdev >= 0.4])
fi
if test "x$BUILD_PSMCOMM" = xyes; then
AC_DEFINE(BUILD_PSMCOMM, 1, [Optional backend psmcomm enabled])