summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorUri Lublin <uril@redhat.com>2012-02-26 16:33:44 +0200
committerUri Lublin <uril@redhat.com>2012-05-23 18:38:51 +0300
commite059de1d00a0df5c4176a768619e4b355d8880a6 (patch)
treeddf5c489db39a6588818f444dcd69c1b17ece214 /configure.ac
parente83a740c5068065dc87d9ec7b8e59cc4d6cee502 (diff)
configure: Windows: ignore usbredirserver and usbredirtestclient subdirs
Their build fails, so skip them. Things to fix to make the them work on Win32 include sockets, signals, threads and more.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8c72972..60fda74 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,6 +26,19 @@ AC_PROG_LN_S
LT_INIT
dnl AC_DEFINE(_GNU_SOURCE, [1], [Enable GNU extensions])
+AC_MSG_CHECKING([for native Win32])
+echo "host is $host"
+case "$host" in
+ *mingw*|*cygwin*)
+ os_win32=yes
+ ;;
+ *)
+ os_win32=no
+ ;;
+esac
+AC_MSG_RESULT([$os_win32])
+AM_CONDITIONAL([OS_WIN32],[test "$os_win32" = "yes"])
+
# Set some sane default CFLAGS, avoid having to do another release like 0.4.1
if test "$ac_test_CFLAGS" != set; then
DEFAULT_CFLAGS="-Wall -Werror -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector --param=ssp-buffer-size=4"