summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2017-03-07 21:24:00 -0800
committerMatt Turner <mattst88@gmail.com>2017-03-07 21:24:05 -0800
commit58b69eedd3bd3d9032a36fbc8ced8b187025aeb2 (patch)
tree96d3d37a0a40de24b8560e4c7b62737e2686cf0a /configure.ac
parent0b361f9d35e4c079b7314c615e0dd5f7ed196758 (diff)
Revert "configure.ac: Use PKG_CHECK_VAR for wayland-scanner."
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8fbadc80e6..d64ed2d3e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2102,7 +2102,12 @@ if test "x$with_egl_platforms" != "x" -a "x$enable_egl" != xyes; then
AC_MSG_ERROR([cannot build egl state tracker without EGL library])
fi
-PKG_CHECK_VAR([WAYLAND_SCANNER], [wayland-scanner], [wayland_scanner])
+PKG_CHECK_MODULES([WAYLAND_SCANNER], [wayland-scanner],
+ WAYLAND_SCANNER=`$PKG_CONFIG --variable=wayland_scanner wayland-scanner`,
+ WAYLAND_SCANNER='')
+if test "x$WAYLAND_SCANNER" = x; then
+ AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner])
+fi
# Do per-EGL platform setups and checks
egl_platforms=`IFS=', '; echo $with_egl_platforms`