summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLucas Baudin <xapantu@gmail.com>2011-12-13 20:10:45 +0100
committerDavid King <amigadave@amigadave.com>2011-12-13 23:15:38 +0100
commitfe532b663ad7624dcacaaf27bb7cc1c20fedab4f (patch)
tree9dfe90bf0233a78693e06b1364a6b0a739dec010 /Makefile.am
parent27cd08b9185dafab39b1bb7804314929d25f3396 (diff)
Add simple test suite, bug 663148
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 4903186..fa6e782 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -370,12 +370,15 @@ dist_pixmaps_DATA = \
# Tests.
check_PROGRAMS = tests/test-widgets
-tests_test_widgets_SOURCES = tests/test-widgets.c
+tests_test_widgets_SOURCES = \
+ libcheese/um-crop-area.c \
+ tests/test-widgets.c
tests_test_widgets_CPPFLAGS = $(EXAMPLES_CPPFLAGS)
tests_test_widgets_LDADD = \
$(CHEESE_LIBS) \
$(CHEESE_GTK_LIBS) \
- libcheese-gtk.la
+ libcheese-gtk.la \
+ libcheese.la
if CHEESE_ENABLE_TESTS
# test: run all tests.