summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid King <amigadave@amigadave.com>2011-12-25 11:46:54 +0100
committerDavid King <amigadave@amigadave.com>2011-12-25 12:07:15 +0100
commitb8db33aa6bff6ff909ab56760c781c812e101ca1 (patch)
tree8df201d07fbdc7c89845e5bc250f62f74d81f76c /Makefile.am
parent12ed0dce60e9d65913b67b7f24a5e480677a09e4 (diff)
Remove .gcno files during clean, not lcov-clean
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d63689a..11a9d1d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -447,14 +447,14 @@ lcov: full-report
lcov-clean:
$(AM_V_at)$(LCOV) --directory $(top_builddir) -z
$(AM_V_at)rm -rf cheese-lcov.info cheese-lcov
- $(AM_V_at)find \( -name '*.gcda' -o -name '*.gcno' \) -exec rm -f {} +
+ $(AM_V_at)find -name '*.gcda' -exec rm -f {} +
else # !CHEESE_ENABLE_LCOV
lcov:
$(AM_V_at)echo "Code coverage reporting not available"
lcov-clean:
$(AM_V_at)rm -rf cheese-lcov.info cheese-lcov
- $(AM_V_at)find \( -name '*.gcda' -o -name '*.gcno' \) -exec rm -f {} +
+ $(AM_V_at)find -name '*.gcda' -exec rm -f {} +
endif
# gtk-doc
@@ -469,6 +469,7 @@ check-local: test
cd $(gtkdoc_builddir) && $(MAKE) $(AM_MAKEFlAGS) check
clean-local: lcov-clean
cd $(gtkdoc_builddir) && $(MAKE) $(AM_MAKEFLAGS) clean
+ find -name '*.gcno' -exec rm -f {} +
distclean-local:
cd $(gtkdoc_builddir) && $(MAKE) $(AM_MAKEFLAGS) distclean
docs: $(lib_LTLIBRARIES)