summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid King <amigadave@amigadave.com>2011-11-21 20:42:50 +0100
committerDavid King <amigadave@amigadave.com>2011-11-21 20:51:19 +0100
commit729939473c4f33b53b574eb970ce52781277b5c2 (patch)
tree4657543e05db812eb7ab7690d921c7ebdf1df5ee /Makefile.am
parent634eca2caba2cec75b223534d34ad436ee5a06f1 (diff)
Remove marshaller generation rules
The generic marshallers, supplied by GLib, are used instead.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 0 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index ceb8737..698e558 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,16 +2,6 @@ ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
SUBDIRS = po help
-marshal_data = \
- libcheese/cheese-marshal.c \
- libcheese/cheese-marshal.h
-
-libcheese/cheese-marshal.h: libcheese/cheese-marshal.list
- $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=cheese_marshal $< > $@
-
-libcheese/cheese-marshal.c: libcheese/cheese-marshal.list libcheese/cheese-marshal.h
- $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --body --prefix=cheese_marshal $< > $@
-
enum_data = \
libcheese/cheese-enums.c \
libcheese/cheese-enums.h
@@ -135,7 +125,6 @@ libcheese_la_LDFLAGS = \
libcheese_la_SOURCES = \
libcheese/cheese-enums.c \
- libcheese/cheese-marshal.c \
libcheese/cheese-camera.c \
libcheese/cheese-camera-device.c \
libcheese/cheese-camera-device-monitor.c \
@@ -173,7 +162,6 @@ Cheese_3_0_gir_CFLAGS = \
$(CHEESE_CFLAGS)
Cheese_3_0_gir_FILES = \
$(libcheese_la_SOURCES) \
- libcheese/cheese-marshal.h \
libcheese/cheese-enums.h
Cheese_3_0_gir_INCLUDES = \
GObject-2.0 \
@@ -425,7 +413,6 @@ dist_noinst_DATA = \
$(noinst_libcheese_headers) \
$(noinst_libcheese_gtk_headers) \
libcheese/cheese-gtk.symbols \
- libcheese/cheese-marshal.list \
m4/introspection.m4 \
src/vapi/cheese-common.deps \
src/vapi/cheese-common.vapi \
@@ -440,7 +427,6 @@ CLEANFILES = \
$(desktop_DATA) \
$(gsettings_SCHEMAS) \
$(pkgconfig_DATA) \
- $(marshal_data) \
$(enum_data) \
$(gir_DATA) \
$(typelib_DATA)