summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid King <amigadave@amigadave.com>2011-12-24 19:50:03 +0100
committerDavid King <amigadave@amigadave.com>2011-12-24 19:52:56 +0100
commit3c6099fe9310e5dbea41c512b4394db41b7eacf1 (patch)
treead9c5ed01042b1441ec5c7095f941d914216aaf1 /Makefile.am
parent8e9260e9674b9b75d750206e4317f96d10eef510 (diff)
Clean all files generated by lcov report creation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 34a2c4a..ec878da 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -447,14 +447,14 @@ lcov: full-report
lcov-clean:
$(AM_V_at)$(LCOV) --directory $(top_builddir) -z
$(AM_V_at)rm -rf cheese-lcov.info cheese-lcov
- $(AM_V_at)find -name '*.gcda' -exec rm -f {} +
+ $(AM_V_at)find \( -name '*.gcda' -o -name '*.gcno' \) -exec rm -f {} +
else # !CHEESE_ENABLE_LCOV
lcov:
$(AM_V_at)echo "Code coverage reporting not available"
lcov-clean:
$(AM_V_at)rm -rf cheese-lcov.info cheese-lcov
- $(AM_V_at)find -name '*.gcda' -exec rm -f {} +
+ $(AM_V_at)find \( -name '*.gcda' -o -name '*.gcno' \) -exec rm -f {} +
endif
# gtk-doc