summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJon TURNEY <jon.turney@dronecode.org.uk>2013-06-14 15:45:27 +0100
committerJon TURNEY <jon.turney@dronecode.org.uk>2013-06-15 12:36:55 +0100
commit53cf43b275964a84ed2a3fb9c05a77521e07d074 (patch)
tree141059b63b953db816f92e555e8f67ac005c56f8 /configure.ac
parent3673fcb94804ae4e31e20a5d18f7f4e43850098f (diff)
Refactor as a library, which can be used by XWin X server, and a test application
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 6 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 40b25b0..f451a42 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,7 +5,7 @@ AC_INIT(xwinclip, 1.2.0)
AC_CONFIG_SRCDIR(xwinclip.c)
AC_CANONICAL_HOST
-AM_INIT_AUTOMAKE([dist-bzip2])
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_CONFIG_HEADER(config.h)
@@ -13,20 +13,19 @@ dnl Checks for programs.
AC_PROG_CC
AC_PROG_CPP
AC_PROG_INSTALL
+AC_PROG_LIBTOOL
AC_PROG_LN_S
AC_PROG_MAKE_SET
dnl Checks for libraries.
-
-
+NEEDED="xfixes x11"
+PKG_CHECK_MODULES(XWINCLIP, $NEEDED)
+AC_SUBST(NEEDED)
dnl Checks for header files.
-
dnl Checks for library functions.
-AC_PATH_X
-AC_PATH_XTRA
dnl Checks for host
@@ -40,5 +39,5 @@ case $host_os in
;;
esac
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([xwinclip.pc Makefile])
AC_OUTPUT