summaryrefslogtreecommitdiff
path: root/os/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'os/meson.build')
-rw-r--r--os/meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/os/meson.build b/os/meson.build
index eb8fcf55d..0e41f9c02 100644
--- a/os/meson.build
+++ b/os/meson.build
@@ -56,9 +56,13 @@ endif
rpc_dep = []
if get_option('secure-rpc')
- # prefer libtirpc (if available), otherwise assume RPC functions are
+ # prefer libtirpc (if available), otherwise ensure RPC functions are
# provided by libc.
rpc_dep = dependency('libtirpc', required: false)
+ if not (rpc_dep.found() or cc.has_header('rpc/rpc.h'))
+ error('secure-rpc requested, but neither libtirpc or libc RPC support were found')
+ endif
+
srcs_os += 'rpcauth.c'
endif