summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThierry Reding <treding@nvidia.com>2018-03-28 14:04:38 +0200
committerAdam Jackson <ajax@redhat.com>2018-03-28 09:54:27 -0400
commit4303deae78c4e2a60856be87bf87cd1643c268f5 (patch)
treed8a107e0f91f45202a1a0d78c02b14daf60ee573 /meson.build
parent465b38cadd573ce50eca959f4b56bf4a6a638d91 (diff)
meson: Properly extract ABI versions for xorg-server.pc
The newline in the middle of the awk expression confuses Meson and causes it to pass only the string before the newline to awk, which will subsequently fail because it encounters an unterminated string. One fix would be to escape the newlines ('\\n'), but that causes the newline to end up in the pkg-config file and separate the ABI version lines by blank lines. Instead, simply drop the newlines to make the generated pkg-config file look more like the one generated as part of the autotools-based build. Signed-off-by: Thierry Reding <treding@nvidia.com> Reviewed-by: Adam Jackson <ajax@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 5feb8338e..9b8da6764 100644
--- a/meson.build
+++ b/meson.build
@@ -602,25 +602,25 @@ if build_xorg
sdkconfig.set('abi_ansic',
run_command(awk, '-F', '[(,)]',
- '/^#define ABI_ANSIC.*SET/ { printf "%d.%d\n", $2, $3 }',
+ '/^#define ABI_ANSIC.*SET/ { printf "%d.%d", $2, $3 }',
files('hw/xfree86/common/xf86Module.h')
).stdout()
)
sdkconfig.set('abi_videodrv',
run_command(awk, '-F', '[(,)]',
- '/^#define ABI_VIDEODRV.*SET/ { printf "%d.%d\n", $2, $3 }',
+ '/^#define ABI_VIDEODRV.*SET/ { printf "%d.%d", $2, $3 }',
files('hw/xfree86/common/xf86Module.h')
).stdout()
)
sdkconfig.set('abi_xinput',
run_command(awk, '-F', '[(,)]',
- '/^#define ABI_XINPUT.*SET/ { printf "%d.%d\n", $2, $3 }',
+ '/^#define ABI_XINPUT.*SET/ { printf "%d.%d", $2, $3 }',
files('hw/xfree86/common/xf86Module.h')
).stdout()
)
sdkconfig.set('abi_extension',
run_command(awk, '-F', '[(,)]',
- '/^#define ABI_EXTENSION.*SET/ { printf "%d.%d\n", $2, $3 }',
+ '/^#define ABI_EXTENSION.*SET/ { printf "%d.%d", $2, $3 }',
files('hw/xfree86/common/xf86Module.h')
).stdout()
)