summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2014-01-22 19:17:24 -0800
committerKeith Packard <keithp@keithp.com>2014-01-27 11:38:36 -0800
commit0b5a87f37d5dcd2ebff977a3b9a50a75ace93c83 (patch)
treee03c20a7f74ce7bfe7c5ac3fdf8e0c17277f0e62 /Makefile.am
parent61cb6c9aa95aa369573c4e02c023bbc33c7678c9 (diff)
pseudoramiX: Only compile on XQUARTZ and XWIN
PseudoramiXExtensionInit() is not defined in extinit.h if it won't be used and we get a compiler warning when compiling the pseudoramiX code. Signed-off-by: Keith Packard <keithp@keithp.com> Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index add69d193..b296e0cfa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,6 +27,10 @@ if PRESENT
PRESENT_DIR=present
endif
+if PSEUDORAMIX
+PSEUDORAMIX_DIR=pseudoramiX
+endif
+
SUBDIRS = \
doc \
man \
@@ -37,11 +41,11 @@ SUBDIRS = \
Xext \
miext \
os \
- pseudoramiX \
randr \
render \
Xi \
xkb \
+ $(PSEUDORAMIX_DIR) \
$(DBE_DIR) \
$(RECORD_DIR) \
xfixes \