summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJon TURNEY <jon.turney@dronecode.org.uk>2012-02-22 16:41:48 +0000
committerJon TURNEY <jon.turney@dronecode.org.uk>2012-02-23 18:42:09 +0000
commitd82f7dc78329fc1aaf4e9edecf22cd934f620036 (patch)
tree5d03e98b88429d7c185ec2817d13b19ced831de6 /Makefile.am
parent56065e872fe7094efc603bb4c3b0221ff3bc7b28 (diff)
xlaunch can now use libxml2
Rename config.cc as config_msxml.cc Add config_libxml2.cc, new implementation Keep it named config.cc and link to new name for ease of applying patches Based on a patch taken from VcXsrv git on sourceforge which uses the GPLv3 license
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 21766a9..5f582f2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,12 +5,12 @@ if DEBUG
DEBUG_FLAGS=-D_DEBUG
endif
-AM_CXXFLAGS = $(DEBUG_FLAGS) -Wall $(HTMLHELP_CFLAGS)
-LDADD = -lcomctl32 $(LIBX11_LIBS) $(HTMLHELP_LDFLAGS)
+AM_CXXFLAGS = $(DEBUG_FLAGS) -Wall $(HTMLHELP_CFLAGS) $(LIBXML2_CFLAGS)
+LDADD = -lcomctl32 $(LIBX11_LIBS) $(HTMLHELP_LDFLAGS) $(LIBXML2_LIBS)
AM_LDFLAGS = -mwindows
xlaunch_SOURCES = \
- config.cc \
+ config_libxml2.cc \
main.cc \
window/dialog.cc \
window/util.cc \