summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-05-21 17:09:40 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-05-21 17:09:40 -0700
commita73284c7aeeab7ee0c1b6027819955ef7b08f23d (patch)
tree3f0c372f3603707e3111bdb12844875884d8eb8c /Makefile.am
parent8942f1fd8377c0e67e5ad493af55b7d7b3f996c7 (diff)
Replace static ChangeLog with dist hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1be6bb3..babc2f3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -99,5 +99,9 @@ xinitrc_DATA = xinitrc
CLEANFILES = xinitrc startx $(appman_DATA)
EXTRA_DIST = xinitrc.cpp startx.cpp $(appman_PRE) \
- startx.cmd xinitrc.cmd xinit.def
+ startx.cmd xinitrc.cmd xinit.def ChangeLog autogen.sh
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog