summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSergii Romantsov <sergii.romantsov@gmail.com>2018-06-08 12:19:01 +0300
committerDylan Baker <dylan@pnwbakers.com>2018-06-12 08:47:38 -0700
commitc9d7f1fab56acf76095b70745c81d6f9778a10aa (patch)
tree9869be54ec1c5c93ecf5c4f727e46e405a9d71b7 /CMakeLists.txt
parent8497129477250648a7379ded1bb3024e7897d7a3 (diff)
cmake: Use Policy CMP0072 as OLD by default.
If system has installed both GL libraries such as Legacy and GLVND, cmake will dump warning: "OpenGL_GL_PREFERENCE has not been set to "GLVND" or "LEGACY", so for compatibility with CMake 3.10 and below the legacy GL library will be used." Added usage of Policy CMP0072 as OLD (that selects LEGACY-library libGL.so by default). Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=106857 Signed-off-by: Sergii Romantsov <sergii.romantsov@globallogic.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ae06737f9..413cd72e6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,10 @@ if (POLICY CMP0042)
cmake_policy (SET CMP0042 NEW)
endif()
+if (POLICY CMP0072)
+ cmake_policy (SET CMP0072 OLD)
+endif()
+
project (piglit)
# Require MinGW