summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDylan Baker <baker.dylan.c@gmail.com>2015-03-04 15:21:58 -0800
committerDylan Baker <baker.dylan.c@gmail.com>2015-03-04 15:23:20 -0800
commit81dcbc778adc99917da16e7f604b451c79fac87a (patch)
treeb09fb9ce1ef6dc1c7c232535d35f9183c53ff075 /CMakeLists.txt
parent69d52c4902118ac47af2b486149d1240e11f4e82 (diff)
CMakeList.txt: Install OpenCL inc files.
These are needed to pass tests, but they weren't being installed for running out of tree. Fixes ~100 warns when running out of tree with beignet. Trivial. Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 19028cbb4..db922d891 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -469,7 +469,7 @@ install (
install (
DIRECTORY tests
DESTINATION ${PIGLIT_INSTALL_LIBDIR}
- FILES_MATCHING REGEX ".*\\.(py|program_test|shader_test|frag|vert|geom|tesc|tese|ktx|cl|txt|vpfp)$"
+ FILES_MATCHING REGEX ".*\\.(py|program_test|shader_test|frag|vert|geom|tesc|tese|ktx|cl|txt|vpfp|inc)$"
REGEX "CMakeFiles|CMakeLists" EXCLUDE
)
@@ -480,6 +480,13 @@ install (
REGEX "CMakeFiles|CMakeLists" EXCLUDE
)
+install (
+ DIRECTORY generated_tests
+ DESTINATION ${PIGLIT_INSTALL_LIBDIR}
+ FILES_MATCHING REGEX ".*\\.inc$"
+ REGEX "CMakeFiles|CMakeLists" EXCLUDE
+)
+
if (WIN32)
set (PYTHON_SUFFIX ".py")
else ()