summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNicolai Hähnle <nicolai.haehnle@amd.com>2018-12-05 13:28:03 +0100
committerNicolai Hähnle <nicolai.haehnle@amd.com>2018-12-07 16:26:14 +0100
commit4275cae95c8cb217d6164dfeeafae7b56484b13d (patch)
tree37f34a6222c5e96cb76547ae8a5ed4391a220d22 /meson.build
parent2845c492187bbf763e06c5b4325fdac8fdc027c8 (diff)
meson: link LLVM 'native' component when LLVM is available
Linking against LLVM built with BUILD_SHARED_LIBS fails otherwise, as the component is required for the draw module. Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 9ea31ab3ae..4f6176b8d9 100644
--- a/meson.build
+++ b/meson.build
@@ -1162,7 +1162,7 @@ endif
llvm_modules = ['bitwriter', 'engine', 'mcdisassembler', 'mcjit']
llvm_optional_modules = []
if with_amd_vk or with_gallium_radeonsi or with_gallium_r600
- llvm_modules += ['amdgpu', 'bitreader', 'ipo']
+ llvm_modules += ['amdgpu', 'native', 'bitreader', 'ipo']
if with_gallium_r600
llvm_modules += 'asmparser'
endif