summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2018-07-12 11:41:37 -0700
committerEric Anholt <eric@anholt.net>2018-07-13 13:29:29 -0700
commit162fcdad6a9db9819f4c18d6f5f4083e50edc00a (patch)
treecc728ee11c77435a9d367c243862237a37cc90cf /meson.build
parent695a4cb0f6120463d16d3e0ef747675a83b769ea (diff)
meson: Move xvmc test tools from unit tests to installed tools.
These are not unit tests, as they rely on the host's XVMC and some user configuration. Switch them over to being general installed tools, to fix unit testing. Fixes: 22a817af8a89 ("meson: build gallium xvmc state tracker") Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 7d12af3d51..e05645cbf3 100644
--- a/meson.build
+++ b/meson.build
@@ -58,7 +58,7 @@ with_osmesa = get_option('osmesa')
with_swr_arches = get_option('swr-arches')
with_tools = get_option('tools')
if with_tools.contains('all')
- with_tools = ['freedreno', 'glsl', 'intel', 'nir', 'nouveau']
+ with_tools = ['freedreno', 'glsl', 'intel', 'nir', 'nouveau', 'xvmc']
endif
dri_drivers_path = get_option('dri-drivers-path')