summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJuan A. Suarez Romero <jasuarez@igalia.com>2018-06-18 15:45:51 +0200
committerJuan A. Suarez Romero <jasuarez@igalia.com>2018-06-21 12:16:46 +0200
commitd24839be70d66cb74f4eb3c5f76b7ed634bdc7d3 (patch)
tree77d618f894daab9c23cddbc1fab9b789079b1059 /configure.ac
parentf966929805f722ae38d4821fab61765c0ee4a60c (diff)
swr: bump minimum supported LLVM version to 5.0
RADV now requires LLVM 5.0 or greater, and thus we can't build dist tarball because swr requires LLVM 4.0. Let's bump required LLVM to 5.0 in swr too. Fixes: f9eb1ef870 ("amd: remove support for LLVM 4.0") Cc: Tim Rowley <timothy.o.rowley@intel.com> Cc: Emil Velikov <emil.velikov@collabora.com> Cc: Dylan Baker <dylan@pnwbakers.com> Cc: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com> Acked-by: Bruce Cherniak <bruce.cherniak@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7af5d9a0e4..a195362007 100644
--- a/configure.ac
+++ b/configure.ac
@@ -110,7 +110,7 @@ LLVM_REQUIRED_OPENCL=3.9.0
LLVM_REQUIRED_R600=3.9.0
LLVM_REQUIRED_RADEONSI=5.0.0
LLVM_REQUIRED_RADV=5.0.0
-LLVM_REQUIRED_SWR=4.0.0
+LLVM_REQUIRED_SWR=5.0.0
dnl Check for progs
AC_PROG_CPP
@@ -2793,8 +2793,9 @@ if test -n "$with_gallium_drivers"; then
fi
# XXX: Keep in sync with LLVM_REQUIRED_SWR
-AM_CONDITIONAL(SWR_INVALID_LLVM_VERSION, test "x$LLVM_VERSION" != x4.0.0 -a \
- "x$LLVM_VERSION" != x4.0.1)
+AM_CONDITIONAL(SWR_INVALID_LLVM_VERSION, test "x$LLVM_VERSION" != x5.0.0 -a \
+ "x$LLVM_VERSION" != x5.0.1 -a \
+ "x$LLVM_VERSION" != x5.0.2)
if test "x$enable_llvm" = "xyes" -a "$with_gallium_drivers"; then
llvm_require_version $LLVM_REQUIRED_GALLIUM "gallium"