summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2018-06-28 15:06:09 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2018-08-07 17:23:17 +0100
commit6b8657aff0adb9952aa3178d3b332de19d354561 (patch)
tree74097522bd75102bf03e4d99b0ef474ab04a4cb8 /configure.ac
parent2f1d9e6cb842e3cff8ae7b73f669ea8d6c411ac8 (diff)
autoconf: stop exporting internal wayland details
With version v1.15 the "code" option was deprecated in favour of "private-code" or "public-code". Before the interface symbol generated was exported (which is a bad idea since it's internal implementation detail) and others may misuse it. That was the case with libva approx. 1 year ago. Since then libva was fixed, so we can finally hide it by using "private-code" Inspired by similar xserver patch by Adam Jackson. Signed-off-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ecc55a11f6..0d67a3499a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1811,6 +1811,10 @@ for plat in $platforms; do
PKG_CHECK_MODULES([WAYLAND_SCANNER], [wayland-scanner],
WAYLAND_SCANNER=`$PKG_CONFIG --variable=wayland_scanner wayland-scanner`,
WAYLAND_SCANNER='')
+ PKG_CHECK_EXISTS([wayland-scanner >= 1.15],
+ AC_SUBST(SCANNER_ARG, 'private-code'),
+ AC_SUBST(SCANNER_ARG, 'code'))
+
if test "x$WAYLAND_SCANNER" = x; then
AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner], [:])
fi