summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2018-06-07 15:45:01 +0100
committerEric Engestrom <eric.engestrom@intel.com>2018-06-08 16:45:43 +0100
commit37eb56d239986e2e7ca1c87d08fd357378a3a06e (patch)
tree6d65cb2e6a1285c67b4524718c0be6a12a6bda08 /configure.ac
parentcb03803253b026d5f4c1e0fef431a12df461e6d8 (diff)
autotools/meson: compile against wayland-egl-*backend*
Bug: https://bugs.freedesktop.org/show_bug.cgi?id=106861 Fixes: 1db4ec05462914096b1f "egl: rewire the build systems to use libwayland-egl" Suggested-by: Emil Velikov <emil.l.velikov@gmail.com> Tested-by: Andreas Hartmetz <ahartmetz@gmail.com> Signed-off-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 875c47fcd4..75ee1a7c01 100644
--- a/configure.ac
+++ b/configure.ac
@@ -90,7 +90,7 @@ LIBOMXIL_TIZONIA_REQUIRED=0.10.0
LIBVA_REQUIRED=0.39.0
VDPAU_REQUIRED=1.1
WAYLAND_REQUIRED=1.11
-WAYLAND_EGL_REQUIRED=1.15
+WAYLAND_EGL_BACKEND_REQUIRED=3
WAYLAND_PROTOCOLS_REQUIRED=1.8
XCB_REQUIRED=1.9.3
XCBDRI2_REQUIRED=1.8
@@ -1810,7 +1810,7 @@ for plat in $platforms; do
PKG_CHECK_MODULES([WAYLAND_SERVER], [wayland-server >= $WAYLAND_REQUIRED])
PKG_CHECK_MODULES([WAYLAND_PROTOCOLS], [wayland-protocols >= $WAYLAND_PROTOCOLS_REQUIRED])
if test "x$enable_egl" = xyes; then
- PKG_CHECK_MODULES([WAYLAND_EGL], [wayland-egl >= $WAYLAND_EGL_REQUIRED])
+ PKG_CHECK_MODULES([WAYLAND_EGL], [wayland-egl-backend >= $WAYLAND_EGL_BACKEND_REQUIRED])
fi
WAYLAND_PROTOCOLS_DATADIR=`$PKG_CONFIG --variable=pkgdatadir wayland-protocols`