summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2012-12-11 17:55:24 +0100
committerMarcel Holtmann <marcel@holtmann.org>2012-12-11 17:55:24 +0100
commite57efd6fbb0a25a61bd841cb1f81ebbd53528a0c (patch)
treeebf783853ed28364f9de1c29c46e60f4664150ba /configure.ac
parent7ef17a931b2c97c8c1d26bdd5cd2b5e508a01489 (diff)
build: Add option for D-Bus system bus services directory
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 50927e4ef..203d6473f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,6 +74,19 @@ if (test -z "${path_dbusconfdir}"); then
AC_SUBST(DBUS_CONFDIR, [${path_dbusconfdir}])
fi
+AC_ARG_WITH([dbussystembusdir], AC_HELP_STRING([--with-dbussystembusdir=DIR],
+ [path to D-Bus system bus services directory]),
+ [path_dbussystembusdir=${withval}])
+if (test -z "${path_dbussystembusdir}"); then
+ AC_MSG_CHECKING([D-Bus system bus services dir])
+ path_dbussystembusdir="`$PKG_CONFIG --variable=system_bus_services_dir dbus-1`"
+ if (test -z "${path_dbusconfdir}"); then
+ AC_MSG_ERROR([D-Bus system bus services directory is required])
+ fi
+ AC_MSG_RESULT([${path_dbussystembusdir}])
+ AC_SUBST(DBUS_SYSTEMBUSDIR, [${path_dbussystembusdir}])
+fi
+
AC_ARG_ENABLE(library, AC_HELP_STRING([--enable-library],
[install Bluetooth library]), [enable_library=${enableval}])
AM_CONDITIONAL(LIBRARY, test "${enable_library}" = "yes")