summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@redhat.com>2009-08-07 00:11:20 -0400
committerSøren Sandmann Pedersen <sandmann@redhat.com>2009-08-07 00:11:20 -0400
commit4ef2807c3a6697731ada43ddad2fa915ed7cfe11 (patch)
tree82276fb113c8fdda8ce5bb76a7d53d3ddf167815 /configure.ac
parent9dec2e352b24bdccaac4f570b8cf12e61a9194ee (diff)
Only define PIXMAN_TIMERS if timers are actually enabled [bug 23169]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ad77b95..a466b86 100644
--- a/configure.ac
+++ b/configure.ac
@@ -462,7 +462,9 @@ AC_ARG_ENABLE(timers,
[enable TIMER_BEGIN and TIMER_END macros [default=no]])],
[enable_timers=$enableval], [enable_timers=no])
-AC_DEFINE(PIXMAN_TIMERS, 1, [enable TIMER_BEGIN/TIMER_END macros])
+if test $enable_timers = yes ; then
+ AC_DEFINE(PIXMAN_TIMERS, 1, [enable TIMER_BEGIN/TIMER_END macros])
+fi
AC_SUBST(PIXMAN_TIMERS)
dnl ===================================