summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmilio Pozuelo Monfort <emilio.pozuelo@collabora.co.uk>2013-12-02 12:53:32 +0100
committerKristian Høgsberg <krh@bitplanet.net>2013-12-02 15:44:49 -0800
commit8a81b83900ae3153a07f0824a57d0daed436fc18 (patch)
tree8b7dfdc6b307078e23b89cb8f4ec7ca209a395b6 /configure.ac
parent3e12e63f034ba6d2c1b27aa5d8f29dde7b0f94db (diff)
Make the default desktop shell client configurable
The default can be set by passing WESTON_SHELL_CLIENT as an argument to configure, similarly to WESTON_NATIVE_BACKEND. Reviewed-by: Bryce Harrington <b.harrington@samsung.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a460d3b6..bd8ff44e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,8 @@ LT_INIT([disable-static])
AC_ARG_VAR([WESTON_NATIVE_BACKEND],
[Set the native backend to use, if Weston is not running under Wayland nor X11. @<:@default=drm-backend.so@:>@])
+AC_ARG_VAR([WESTON_SHELL_CLIENT],
+ [Set the default desktop shell client to load if none is specified in weston.ini. @<:@default=weston-desktop-shell@:>@])
PKG_PROG_PKG_CONFIG()
@@ -456,6 +458,13 @@ AC_MSG_NOTICE([Weston's native backend: $WESTON_NATIVE_BACKEND])
AC_DEFINE_UNQUOTED([WESTON_NATIVE_BACKEND], ["$WESTON_NATIVE_BACKEND"],
[The default backend to load, if not wayland nor x11.])
+if test "x$WESTON_SHELL_CLIENT" = "x"; then
+ WESTON_SHELL_CLIENT="weston-desktop-shell"
+fi
+AC_MSG_NOTICE([Weston's default desktop shell client: $WESTON_SHELL_CLIENT])
+AC_DEFINE_UNQUOTED([WESTON_SHELL_CLIENT], ["$WESTON_SHELL_CLIENT"],
+ [The default desktop shell client to load.])
+
AC_ARG_ENABLE(demo-clients,
AS_HELP_STRING([--enable-demo-clients],
[install demo clients built with weston]),,