summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHardening <rdp.effort@gmail.com>2014-01-10 11:33:06 +0100
committerKristian Høgsberg <krh@bitplanet.net>2014-01-19 22:35:51 -0800
commit04633b69324ef1df086f1f2a2686441937575ccf (patch)
treeb5ed00e9fec643a97d64c4e908e20907009d89e3 /configure.ac
parentac9f35a72b592426809c5698caf9f2c2b55b5ec8 (diff)
Fix compilation with FreeRdp 1.1 and master v2
The API to use remoteFx encoding has changed between master and stable 1.1 branch. This patch should fix compilation for both. This new version adds checks for the freerdp/version.h file
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 571bf601..d66dbec8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -204,6 +204,11 @@ AM_CONDITIONAL([ENABLE_RDP_COMPOSITOR],
if test x$enable_rdp_compositor = xyes; then
AC_DEFINE([BUILD_RDP_COMPOSITOR], [1], [Build the RDP compositor])
PKG_CHECK_MODULES(RDP_COMPOSITOR, [freerdp >= 1.1.0])
+
+ SAVED_CPPFLAGS="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS $RDP_COMPOSITOR_CFLAGS"
+ AC_CHECK_HEADERS([freerdp/version.h])
+ CPPFLAGS="$SAVED_CPPFLAGS"
fi
AC_ARG_WITH(cairo,