summaryrefslogtreecommitdiff
path: root/qt4/tests/lib/glib/future/conference/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'qt4/tests/lib/glib/future/conference/CMakeLists.txt')
-rw-r--r--qt4/tests/lib/glib/future/conference/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/qt4/tests/lib/glib/future/conference/CMakeLists.txt b/qt4/tests/lib/glib/future/conference/CMakeLists.txt
new file mode 100644
index 000000000..2e66ed423
--- /dev/null
+++ b/qt4/tests/lib/glib/future/conference/CMakeLists.txt
@@ -0,0 +1,12 @@
+if(ENABLE_TP_GLIB_TESTS)
+ include_directories(
+ ${CMAKE_SOURCE_DIR}/tests/lib/glib/future)
+
+ set(future_example_cm_conference_SRCS
+ chan.c
+ chan.h)
+
+ add_library(future-example-cm-conference STATIC ${future_example_cm_conference_SRCS})
+ target_link_libraries(future-example-cm-conference ${TPGLIB_LIBRARIES}
+ tp-glib-tests-future-extensions)
+endif(ENABLE_TP_GLIB_TESTS)