summaryrefslogtreecommitdiff
path: root/qt4/tests/lib/glib/echo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'qt4/tests/lib/glib/echo/CMakeLists.txt')
-rw-r--r--qt4/tests/lib/glib/echo/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/qt4/tests/lib/glib/echo/CMakeLists.txt b/qt4/tests/lib/glib/echo/CMakeLists.txt
new file mode 100644
index 000000000..36696a30d
--- /dev/null
+++ b/qt4/tests/lib/glib/echo/CMakeLists.txt
@@ -0,0 +1,18 @@
+if(ENABLE_TP_GLIB_TESTS)
+ include_directories(${CMAKE_CURRENT_BINARY_DIR})
+
+ set(example_cm_echo_SRCS
+ chan.c
+ chan.h
+ conn.c
+ conn.h
+ connection-manager.c
+ connection-manager.h
+ im-manager.c
+ im-manager.h
+ )
+
+ add_library(example-cm-echo STATIC ${example_cm_echo_SRCS})
+ target_link_libraries(example-cm-echo ${TPGLIB_LIBRARIES})
+ tpqt4_generate_manager_file(${CMAKE_CURRENT_SOURCE_DIR}/manager-file.py example_echo.manager connection-manager.c)
+endif(ENABLE_TP_GLIB_TESTS)