summaryrefslogtreecommitdiff
path: root/qt4/tests/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'qt4/tests/lib/CMakeLists.txt')
-rw-r--r--qt4/tests/lib/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/qt4/tests/lib/CMakeLists.txt b/qt4/tests/lib/CMakeLists.txt
new file mode 100644
index 000000000..ac4768911
--- /dev/null
+++ b/qt4/tests/lib/CMakeLists.txt
@@ -0,0 +1,12 @@
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR})
+
+file(MAKE_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/_gen")
+tpqt4_generate_moc_i(test.h ${CMAKE_CURRENT_BINARY_DIR}/_gen/test.h.moc.hpp)
+add_library(tp-qt4-tests test.cpp ${CMAKE_CURRENT_BINARY_DIR}/_gen/test.h.moc.hpp)
+target_link_libraries(tp-qt4-tests ${QT_QTCORE_LIBRARY} ${QT_QTDBUS_LIBRARY} telepathy-qt4)
+
+if(ENABLE_TP_GLIB_TESTS)
+ add_subdirectory(glib)
+ add_subdirectory(glib-helpers)
+endif(ENABLE_TP_GLIB_TESTS)