summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohn Brooks <john.brooks@jollamobile.com>2012-11-27 17:42:37 -0700
committerJohn Brooks <john.brooks@jollamobile.com>2012-11-27 17:45:48 -0700
commit54fc8c4e4c00d9ba70b576c2867b66f36de74cbb (patch)
tree1eaaecc75c0fdb53f81be41959853d56fe9e04f9 /configure.ac
parenta680ab50cf8d3eb55ead145f6f1366d585c5f71b (diff)
Add mcp-account-manager-ring to automatically create a Telepathy account
This is a mission-control account manager plugin, which will provide a persistent telepathy-ring account by the name of ring/tel/account0. That account will be enabled and auto-connect by default. If removed, it will be recreated on the next initialization of mission-control.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 27 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2baaeb4..c2f9ad0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,7 +11,6 @@ AC_PROG_CC
AC_PROG_CC_STDC
dnl Not yet
-AC_DISABLE_SHARED
AM_PROG_LIBTOOL
dnl decide on error flags
@@ -33,6 +32,31 @@ if test x$enable_debug = xyes; then
AC_DEFINE([ENABLE_DEBUG], [1], [Enable debug code])
fi
+AC_ARG_ENABLE(mc-account-plugin,
+ AS_HELP_STRING([--enable-mc-account-plugin=@<:@no/yes/auto@:>@],
+ [build MC account plugin]), , enable_mc_account_plugin=auto)
+
+if test "x$enable_mc_account_plugin" != "xno"; then
+ PKG_CHECK_MODULES(MCP,
+ [
+ mission-control-plugins
+ ], have_mcp="yes", have_mcp="no")
+
+ AC_MSG_CHECKING([Mission Control plugins dir])
+ MISSION_CONTROL_PLUGINS_DIR=${libdir}/mission-control-plugins.`pkg-config --variable=MCP_ABI_VERSION mission-control-plugins`
+
+ AC_MSG_RESULT([$MISSION_CONTROL_PLUGINS_DIR])
+ AC_SUBST(MISSION_CONTROL_PLUGINS_DIR)
+else
+ have_mcp=no
+fi
+
+if test "x$enable_mc_account_plugin" = "xyes" -a "x$have_mcp" != "xyes"; then
+ AC_MSG_ERROR([Could not find mission-control plugin dependencies:
+
+$MCP_PKG_ERRORS])
+fi
+
AC_HEADER_STDC
AC_C_INLINE
@@ -97,5 +121,6 @@ AC_CONFIG_FILES([Makefile])
AC_CONFIG_FILES([modem/Makefile modem/tests/Makefile \
src/Makefile tests/Makefile docs/Makefile \
scripts/Makefile \
- tools/Makefile ring-extensions/Makefile])
+ tools/Makefile ring-extensions/Makefile \
+ mc-plugin/Makefile])
AC_OUTPUT