summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2012-05-09 18:58:03 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2012-05-10 12:50:24 +0100
commit9125942834db3a6c37d62b5fb1e49a1a9de0280a (patch)
treeae36f42b277f1bb3e9f26dac5f724cf05ea46545 /configure.ac
parent22e8917948e15000373542b30808f6a5873012d2 (diff)
Link with ld --no-copy-dt-needed-entries if available
Bug: https://bugs.freedesktop.org/show_bug.cgi?id=49725 Signed-off-by: Simon McVittie <simon.mcvittie@collabora.co.uk> Reviewed-by: Mikhail Zabaluev <mikhail.zabaluev@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aa461e3..0795eed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -70,6 +70,12 @@ TP_COMPILER_WARNINGS([ERROR_CFLAGS], [test "x$enable_fatal_warnings" = xyes],
unused-parameter])
AC_SUBST([ERROR_CFLAGS])
+# these aren't really error flags but they serve a similar purpose for us -
+# making the toolchain stricter
+if test "x$enable_fatal_warnings" = xyes; then
+ TP_ADD_LINKER_FLAG([ERROR_LDFLAGS], [-Wl,--no-copy-dt-needed-entries])
+fi
+
AC_ARG_ENABLE(debug,
AS_HELP_STRING([--disable-debug],[omit debug code]),
enable_debug=$enableval, enable_debug=yes )