summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlex Wu <zhiwen.wu@linux.intel.com>2012-05-02 14:52:04 +0800
committerKristian Høgsberg <krh@bitplanet.net>2012-05-02 10:22:22 -0400
commitb12c2995da04d6411ab058dfcffea84356ad5e55 (patch)
treeff75a8cc24ce2c82616f9693236bb0b2bbff75f8 /configure.ac
parentebe0ddf657903bef32a161dc66254fbf8725f986 (diff)
eglut: Add wayland support
This patch adds wayland support for eglut, so that the demos based on eglut can run on wayland platform.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4f6f16f2..be9caa16 100644
--- a/configure.ac
+++ b/configure.ac
@@ -206,6 +206,16 @@ if test "x$x11_enabled" != "xno"; then
PKG_CHECK_MODULES(X11, [x11 xext], [x11_enabled=yes], [x11_enabled=no])
fi
+AC_ARG_ENABLE([wayland],
+ [AS_HELP_STRING([--enable-wayland],
+ [enable support for wayland @<:@default=no@:>@])],
+ [wayland_enabled="$enableval"],
+ [wayland_enabled=no])
+
+if test "x$wayland_enabled" != "xno"; then
+ PKG_CHECK_MODULES(WAYLAND, [wayland-client wayland-egl], [wayland_enabled=yes], [wayland_enabled=no])
+fi
+
dnl GBM is needed for EGL on KMS
AC_ARG_ENABLE([gbm],
[AS_HELP_STRING([--enable-gbm],
@@ -283,6 +293,9 @@ AC_SUBST([OSMESA_LIBS])
AC_SUBST([OSMESA16_LIBS])
AC_SUBST([OSMESA32_LIBS])
AC_SUBST([MESA_GLAPI])
+AC_SUBST([WAYLAND_CFLAGS])
+AC_SUBST([WAYLAND_LIBS])
+
AM_CONDITIONAL(HAVE_EGL, test "x$egl_enabled" = "xyes")
AM_CONDITIONAL(HAVE_GLESV1, test "x$glesv1_enabled" = "xyes")
@@ -296,6 +309,7 @@ AM_CONDITIONAL(HAVE_OSMESA, test "x$osmesa_enabled" = "xyes")
AM_CONDITIONAL(HAVE_DRM, test "x$drm_enabled" = "xyes")
AM_CONDITIONAL(BUILD_GLTRACE, false)
AM_CONDITIONAL(HAVE_MESA_SOURCE, test "x$mesa_source_enabled" = "xyes")
+AM_CONDITIONAL(HAVE_WAYLAND, test "x$wayland_enabled" = "xyes")
AC_OUTPUT([
Makefile