summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJosé Fonseca <jfonseca@vmware.com>2011-08-02 20:17:50 +0100
committerJosé Fonseca <jfonseca@vmware.com>2011-08-02 20:17:50 +0100
commit838c703bb9be6d89a226f2239dbb44c85d53da57 (patch)
tree59c0f560dfca62a540efee50dccd83fec205638f /CMakeLists.txt
parent0116f825acbd7209518273432183f1adb738a836 (diff)
cmake: Allow to specify glext headers include path.
In order to pick different (i.e., newer) headers than the system ones.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dbb33592..48f218f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,6 +16,20 @@ find_path (GLEW_INCLUDE_DIR GL/glew.h
/usr/include/GL
)
+if (APPLE)
+ find_path(GLEXT_INCLUDE_DIR
+ NAMES OpenGL/glext.h
+ PATHS ${OPENGL_INCLUDE_DIR}
+ DOC "Include for OpenGL/glext.h on OSX"
+ )
+else (APPLE)
+ find_path(GLEXT_INCLUDE_DIR
+ NAMES GL/glext.h
+ PATHS ${OPENGL_INCLUDE_DIR}
+ DOC "Include for GL/glext.h"
+ )
+endif (APPLE)
+
if (UNIX)
link_libraries(m)
endif (UNIX)