summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMurray Cumming <murrayc@openismus.com>2012-11-08 10:25:44 +0100
committerMurray Cumming <murrayc@murrayc.com>2012-11-09 10:21:14 +0100
commit851e7931a8079520d72990ab5133a92563f95275 (patch)
tree8ecf1082c74b308c2b721b38293cea97b3cd8237 /Makefile.am
parentf78d298bf1975fcaa21c4fb48d2852c0b31bdbdf (diff)
Add gtk-doc documentation generation
* configure.ac, Makefile.am, doc/Makefile.am: Add use of gtk-doc, disabled by default but enabled during dist. * doc/grilo-plugins/: Start with the *.types, and the main *-docs.xml page, with an overview.xml. * src/*/*.c: Add gtk-doc comments to the *Source types so that they appear in the documentation. These should later contain documentation about what full-text search and query syntax each plugin supports, as suggested in bug #685473 * Makefile.am: Do not make docs an optional part of SUBDIRS, because we need to install the distribute html even when the generation of that html is disabled.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4b9e922..e2eda7d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,7 +7,7 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = src
+SUBDIRS = src doc
MAINTAINERCLEANFILES = \
aclocal.m4 \
@@ -30,6 +30,8 @@ DISTCLEANFILES = $(MAINTAINERCLEANFILES)
EXTRA_DIST = ./m4/grilo.m4
+DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
+
distclean-local:
-rm -rf autom4te.cache