summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2013-10-19 13:03:55 -0400
committerDan Winship <danw@gnome.org>2013-11-20 09:16:16 -0500
commit51a917bc1656368e8d94ea7ea3b33d3cc06daa82 (patch)
treed3ca4b465af9b0d1247d132644736661fa99ce7a /configure.ac
parent57969f4b251d14eaa3d154842f208dde4cc525a7 (diff)
Remove alleged support for BeOS
Since the initial addition of BeOS support in 1999, there has only been one update to it (in 2005, and it wasn't even very big). GLib is known to not currently build on Haiku (or presumably actual BeOS) without additional patching, and the fact that there isn't a single G_OS_BEOS check in gio/ is suspicious. Additionally, other than the GModule implementation, all of the existing G_OS_BEOS checks are either (a) "G_OS_UNIX || G_OS_BEOS", or (b) random minor POSIXy tweaks (include this header file rather than that one, etc), suggesting that if we were going to support Haiku, it would probably be simpler to treat it as a special kind of G_OS_UNIX (as we do with Mac OS X) rather than as its own completely different thing. So, kill G_OS_BEOS. https://bugzilla.gnome.org/show_bug.cgi?id=710519
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 0 insertions, 32 deletions
diff --git a/configure.ac b/configure.ac
index deacdc1ec..26a9cd8fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,17 +117,6 @@ AM_CONDITIONAL(HAVE_GCC, [test "$GCC" = "yes"])
AC_CANONICAL_HOST
-AC_MSG_CHECKING([for the BeOS])
-case $host in
- *-*-beos*)
- glib_native_beos="yes"
- ;;
- *)
- glib_native_beos="no"
- ;;
-esac
-AC_MSG_RESULT([$glib_native_beos])
-
dnl
AC_MSG_CHECKING([for Win32])
@@ -1569,15 +1558,6 @@ AS_IF([ test -z "$G_MODULE_IMPL"], [
[G_MODULE_IMPL=G_MODULE_IMPL_DL],[])],
[])
])
-dnl *** load_image (BeOS)
-AS_IF([test -z "$G_MODULE_IMPL" && test "x$glib_native_beos" = "xyes"], [
- AC_CHECK_LIB(root, load_image,
- [G_MODULE_LIBS="-lbe -lroot -lglib-2.0 "
- G_MODULE_LIBS_EXTRA="-L\$(top_builddir_full)/.libs"
- G_MODULE_PLUGIN_LIBS="-L\$(top_builddir_full)/gmodule/.libs -lgmodule"
- G_MODULE_IMPL=G_MODULE_IMPL_BEOS],
- [])
-])
dnl *** NSLinkModule (dyld) in system libraries (Darwin)
AS_IF([ test -z "$G_MODULE_IMPL" ], [
AC_CHECK_FUNC(NSLinkModule,
@@ -2245,15 +2225,6 @@ if test "x$G_THREAD_LIBS" = xerror; then
AC_MSG_ERROR($LIBS_NOT_FOUND_1$have_threads$LIBS_NOT_FOUND_2)
fi
-case $host in
- *-*-beos*)
- G_THREAD_LIBS="-lbe -lroot -lglib-2.0 "
- G_THREAD_LIBS_EXTRA="-L\$(top_builddir_full)/.libs"
- ;;
- *)
- ;;
-esac
-
AC_MSG_CHECKING(thread related libraries)
AC_MSG_RESULT($G_THREAD_LIBS)
@@ -3585,9 +3556,6 @@ g_module_suffix="$glib_gmodule_suffix"
g_pid_type="$glib_pid_type"
case $host in
- *-*-beos*)
- glib_os="#define G_OS_BEOS"
- ;;
*-*-cygwin*)
glib_os="#define G_OS_UNIX
#define G_PLATFORM_WIN32