summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-08-29 11:39:55 +0300
committerEmil Velikov <emil.l.velikov@gmail.com>2016-08-31 14:56:38 +0100
commitfaf699ae95ee265c76ced49a75578654ad3052e0 (patch)
tree157b58eae251e8547fb584ab2929e6e1e25728e2 /CMakeLists.txt
parentf5622dbe555c974e972741b1f08adf7023f5fd3b (diff)
cmake: Link utils with xcb explicitly
Linking CXX executables with gold linker leads to: libpiglitutil_gl.so.0: error: undefined reference to 'xcb_connect' libpiglitutil_gl.so.0: error: undefined reference to 'xcb_get_setup' libpiglitutil_gl.so.0: error: undefined reference to 'xcb_setup_roots_iterator' This may have appeared now because xcb-dri2 used to overlink publicly but now does not. Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9275743d9..536f77583 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -155,6 +155,7 @@ IF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
pkg_check_modules(LIBDRM QUIET libdrm)
pkg_check_modules(LIBDRM_INTEL QUIET libdrm_intel)
+ pkg_check_modules(XCB QUIET xcb)
pkg_check_modules(XCB_DRI2 QUIET xcb-dri2)
pkg_check_modules(GLPROTO QUIET glproto)
ELSEIF(${CMAKE_SYSTEM_NAME} MATCHES "Windows")