summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2016-08-22 15:32:18 -0700
committerDylan Baker <dylan@pnwbakers.com>2016-08-22 16:18:42 -0700
commit6f075eead42cf37a6da33d5a03b2c6b74c25c9f9 (patch)
tree112f3dc9e5c45fb15b179981a77d080a45ca981b /CMakeLists.txt
parenta6c359becef7c113cf20d9a1cc91764aa1150cd6 (diff)
CMake: Fix GBM version requirement for DMA BUF tests
In commit a1efbfb9 support was added for dmabuf with GBM on non-intel platforms, but the requirements were set incorrectly. They require symbols added in mesa commit 8aeb6d76, which is not in any mesa 11 release, only in mesa 12. This corrects the requirement to be version 12.0 bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=97435 Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 55cfc4541..9275743d9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -141,7 +141,7 @@ IF(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
if(GBM_FOUND)
set(PIGLIT_HAS_GBM True)
add_definitions(-DPIGLIT_HAS_GBM)
- if (GBM_VERSION VERSION_GREATER "11.1")
+ if (GBM_VERSION VERSION_EQUAL "12.0" OR GBM_VERSION VERSION_GREATER "12.0")
set(PIGLIT_HAS_GBM_BO_MAP True)
add_definitions(-DPIGLIT_HAS_GBM_BO_MAP)
endif()