summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuo Jinghua <sunmoon1997@gmail.com>2011-06-12 13:09:41 +0800
committerLuo Jinghua <sunmoon1997@gmail.com>2011-06-12 13:09:41 +0800
commit7d43c08d665cc0703aec5ab8a5b467a7f5bee7ed (patch)
treec0d0c68d4733072fd65b8973900bb6e4d8379416 /configure.ac
parent898ed88397ba222491da5db71fe9e9e8e4d534f6 (diff)
build: check if availablity of x
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8806885..610be2e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -180,6 +180,10 @@ if test "x$enable_opengl" != "xno"; then
AX_CHECK_GL
fi
AM_CONDITIONAL(HAVE_OPENGL, [test "x$no_gl" != x"yes" ])
+AM_CONDITIONAL(HAVE_X, [test "x$no_x" != x"yes" ])
+if test "x$no_x" != x"yes"; then
+ AC_DEFINE_UNQUOTED(HAVE_X, 1, [defined if you have X headers and libraries])],
+fi
SDL_FREETYPE_OPENGLES_REQUIRES="sdl-freetype"
enable_opengles=auto
@@ -200,7 +204,7 @@ if test "x$enable_opengles" != "xno"; then
done
LIBS="$EGL_LIBS $LIBS"
- for gles1_lib in GLES_CM GLESv1_CM; do
+ for gles1_lib in GLES_CM GLESv1_CM GLESv1; do
AC_CHECK_LIB($gles1_lib, glGenTextures,
[GLES_LIBS="-l$gles1_lib"
have_opengles=yes])