summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuo Jinghua <sunmoon1997@gmail.com>2011-06-12 19:58:19 +0800
committerLuo Jinghua <sunmoon1997@gmail.com>2011-06-12 19:58:19 +0800
commit551a4712dbf26ebeaea093cb454c7181db8f1f55 (patch)
treedf2898a147d196156ab4ab8af0b281baa0aadc72 /configure.ac
parent2a31330d1c1309f28abff02e922d5e1877720411 (diff)
Make sdl, fontconfig, opengl and opengles all *really* optional
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 11 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 00df885..61c5f47 100644
--- a/configure.ac
+++ b/configure.ac
@@ -145,11 +145,11 @@ AC_CHECK_FUNCS(FT_GlyphSlot_Embolden FT_Library_SetLcdFilter)
dnl Check for SDL
SDL_VERSION=1.2.4
-enable_sdl=auto
+#enable_sdl=auto
AC_ARG_ENABLE(sdl,
AS_HELP_STRING([--enable-sdl],
[build sdl renderer (sdl must be installed)]),
- [enable_sdl=$enableval], [enable_sdl=no])
+ [], [])
if test "x$enable_sdl" != "xno"; then
AM_PATH_SDL($SDL_VERSION,
@@ -162,11 +162,10 @@ AM_CONDITIONAL(HAVE_SDL, test "x$have_sdl" = "xyes")
CFLAGS="$CFLAGS $SDL_CFLAGS"
LIBS="$LIBS $SDL_LIBS"
-enable_fontconfig=auto
+#enable_fontconfig=auto
AC_ARG_ENABLE(fontconfig,
AS_HELP_STRING([--enable-fontconfig],
- [build sdl-ft (fontconfig must be installed)]),
- [enable_fontconfig=$enableval], [enable_fontconfig=no])
+ [build sdl-ft (fontconfig must be installed)]))
if test "x$enable_fontconfig" != "xno"; then
PKG_CHECK_MODULES(FONTCONFIG, fontconfig,
@@ -174,15 +173,18 @@ if test "x$enable_fontconfig" != "xno"; then
[have_fontconfig=no])
fi
+if test "x$have_fontconfig" == x"yes"; then
+ AC_DEFINE_UNQUOTED(HAVE_FONTCONFIG, 1, [defined if you have fontconfig headers and library])
+fi
AM_CONDITIONAL(HAVE_FONTCONFIG, test "x$have_fontconfig" = "xyes")
SDL_FT_REQUIRES="fontconfig $SDL_FT_REQUIRES"
SDL_FREETYPE_OPENGL_REQUIRES="sdl-freetype"
-enable_opengl=auto
+#enable_opengl=auto
AC_ARG_ENABLE(opengl,
AS_HELP_STRING([--enable-opengl],
[build sdl-freetype-opengl (openl must be available)]),
- [enable_opengl=$enableval], [enable_opengl=no])
+ [], [])
if test "x$enable_opengl" != "xno"; then
AX_CHECK_GL
@@ -194,12 +196,12 @@ if test "x$no_x" != x"yes"; then
fi
SDL_FREETYPE_OPENGLES_REQUIRES="sdl-freetype"
-enable_opengles=auto
+#enable_opengles=auto
have_opengles=no
AC_ARG_ENABLE(opengles,
AS_HELP_STRING([--enable-opengles],
[build sdl-freetype-opengles (opengles must be available)]),
- [enable_opengles=$enableval], [enable_opengles=no])
+ [], [])
if test "x$enable_opengles" != "xno"; then
AC_CHECK_HEADERS([EGL/egl.h GLES/gl.h])