summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac106
1 files changed, 36 insertions, 70 deletions
diff --git a/configure.ac b/configure.ac
index 11a375b..8971504 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,13 +1,17 @@
# -*- Autoconf -*-
m4_define([gst_pps_major], 0)
m4_define([gst_pps_minor], 0)
-m4_define([gst_pps_micro], 16)
+m4_define([gst_pps_micro], 17)
m4_define([gst_pps_nano], 0)
-AC_INIT([gst-plugins-pps], gst_pps_major.gst_pps_minor.gst_pps_micro.gst_pps_nano)
+m4_if(gst_pps_nano, 0,
+ [m4_define(gst_pps_version, gst_pps_major.gst_pps_minor.gst_pps_micro)],
+ [m4_define(gst_pps_version, gst_pps_major.gst_pps_minor.gst_pps_micro.gst_pps_nano)])
+AC_INIT([gst-plugins-pps], gst_pps_version)
dnl AC_INIT([$PACKAGE], [$VERSION])
AC_CONFIG_SRCDIR([config.h.in])
AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_MACRO_DIR([m4])
dnl AM_MAINTAINER_MODE provides the option to enable maintainer mode
dnl AM_MAINTAINER_MODE
@@ -25,11 +29,10 @@ AC_PROG_CPP
AC_PROG_INSTALL
AC_PROG_LN_S
AC_PROG_MAKE_SET
-AC_PROG_RANLIB
AC_PROG_LIBTOOL
dnl Add the languages which your application supports to po/LINGUAS
-GETTEXT_PACKAGE=ppstream
+GETTEXT_PACKAGE=gst-plugins-pps
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, ["$GETTEXT_PACKAGE"], [Define to the Gettext package name])
AC_SUBST(GETTEXT_PACKAGE)
AM_GLIB_GNU_GETTEXT
@@ -148,92 +151,55 @@ AC_LANG(C++)
PPS_DEP_LIBS='-lppsbase -lppssg -lppsvodres -lppsfds -lppsvodnet'
LIBS="-lppsapi $PPS_DEP_LIBS $LIBS"
PPS_LIBS=
-PPS32_LIBS=
-WRAPPER_LDFLAGS="-pthread -lppsapi $PPS_DEP_LIBS"
-WRAPPER_CFLAGS="-pthread"
-WRAPPER_PRELOAD_LDFLAGS="-avoid-version -ldl"
-WRAPPER_PRELOAD_CFLAGS=
+
AC_MSG_CHECKING([whether pps libraris is available])
AC_LINK_IFELSE(AC_LANG_CALL([], ppsvod_create),
[AC_MSG_RESULT(yes)
HAVE_PPS="yes"],
[AC_MSG_RESULT(no)
HAVE_PPS="no"])
-if test "x$HAVE_PPS" = "xyes"; then
- PPS_LIBS="-lppsapi $PPS_DEP_LIBS"
-# AC_DEFINE_UNQUOTED(HAVE_LIBPPS)
-else
- AC_MSG_CHECKING([whether pps 32bit libraris is available])
- saved32LDFLAGS=$LDFLAGS
- LDFLAGS="-m32 $LDFLAGS"
- AC_LINK_IFELSE(AC_LANG_CALL([], ppsvod_destroy),
- [ HAVE_PPS32="yes"
- AC_MSG_RESULT(yes)],
- [ HAVE_PPS32="no"
- AC_MSG_RESULT(no)])
- if test "x$HAVE_PPS32" = "xyes"; then
- PPS32_LIBS="-lppsapi $PPS_DEP_LIBS"
- else
- AC_MSG_ERROR(['couldn't find pps libraries.])
- fi
- LDFLAGS=$saved32LDFLAGS
- WRAPPER_CFLAGS="-m32 $WRAPPER_CFLAGS"
- WRAPPER_LDFLAGS="-m32 $WRAPPER_LDFLAGS"
- WRAPPER_PRELOAD_CFLAGS="-m32 $WRAPPER_PRELOAD_CFLAGS"
- WRAPPER_PRELOAD_LDFLAGS="-m32 $WRAPPER_PRELOAD_LDFLAGS"
- use_wrapper=yes
-# AC_DEFINE_UNQUOTED(HAVE_LIBPPS32)
-fi
LDFLAGS=$savedLDFLAGS
LIBS=$savedLIB
+savedLDFLAGS=$LDFLAGS
+savedLIB=$LIBS
+LIBS="-lppswrapper"
+AC_MSG_CHECKING([whether ppswrapper libraris is available])
+AC_LINK_IFELSE(AC_LANG_CALL([], ppsvod_create),
+ [AC_MSG_RESULT(yes)
+ HAVE_PPSWRAPPER="yes"],
+ [AC_MSG_RESULT(no)
+ HAVE_PPSWRAPPER="no"])
+LDFLAGS=$savedLDFLAGS
+LIBS=$savedLIB
+
+if test "x$HAVE_PPS" = "xno"; then
+ if test "x$HAVE_PPSWRAPPER" = "xno" -o "x$use_wrapper" = "xno";then
+ AC_MSG_ERROR("libpps and libppswrapper aren't available")
+ else
+ use_wrapper=yes
+ fi
+fi
+
+if test "x$HAVE_PPSWRAPPER" = "xno";then
+ use_wrapper=no
+ PPS_LIBS="-lppsapi $PPS_DEP_LIBS"
+else
+ PPS_LIBS="-lppswrapper"
+fi
+
AC_LANG(C)
AC_SUBST(PPS_LIBS)
-AC_SUBST(PPS32_LIBS)
-AC_SUBST(WRAPPER_LDFLAGS)
-AC_SUBST(WRAPPER_CFLAGS)
-AC_SUBST(WRAPPER_PRELOAD_LDFLAGS)
-AC_SUBST(WRAPPER_PRELOAD_CFLAGS)
-
-AM_CONDITIONAL(USE_PPSWRAPPER, [test "x$use_wrapper" != "xno"])
-
-dnl ================================================================
-dnl Totem plugins
-dnl ================================================================
-PLUGINDIR='${libdir}/totem/plugins'
-AC_SUBST(PLUGINDIR)
-
-AC_MSG_CHECKING([whether Totem plugin support is requested])
-AC_ARG_ENABLE([totem],
- AS_HELP_STRING([--enable-totem],[Enable totem support]),
- [enable_totem=$enableval have_totem=$enableval],
- [enable_totem=autodetect have_totem=yes])
-AC_MSG_RESULT([$enable_totem])
-
-if test "x$have_totem" != "xno"; then
- AM_PATH_PYTHON([2.3],[],[have_totem=no])
- if test "x$PYTHON" = "x:"; then
- have_totem=no
- fi
-fi
AC_OUTPUT(Makefile
m4/Makefile
src/Makefile
po/Makefile.in
- wrapper/Makefile
- wrapper/ppswrapper-run-server
- totem/Makefile
- totem/plugin/Makefile)
+ wrapper/Makefile)
if test x$use_wrapper = xyes;then
AC_MSG_NOTICE([** Using pps wrapper])
else
AC_MSG_NOTICE([** Not using pps wrapper, ppssrc may can only be used by root])
fi
-if test x$have_totem = xyes;then
- AC_MSG_NOTICE([** Totem plugin enabled])
-else
- AC_MSG_NOTICE([ Totem plugin disabled])
-fi