summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Harris <pharris@opentext.com>2012-08-16 11:59:14 -0400
committerPeter Harris <pharris@opentext.com>2012-09-18 11:42:23 -0400
commit08cc068ead7b8e678cdb119b38ada5261d5cc3ea (patch)
tree10884817653262c3c3af3273e0f8b4f3b749bebe /configure.ac
parentff53285ae3f604e9f2cc5f4837255220459b5e44 (diff)
Allow xcb_send_request with >MAX_IOV iovecs
This allows an application to do a scatter/gather operation on a large image buffer to avoid the extra memcpy. Use autoconf to use UIO_MAXIOV where IOV_MAX is not available (and the POSIX minimum of 16 where neither are available). Reviewed-by: Uli Schlachter <psychon@znc.in> Signed-off-by: Peter Harris <pharris@opentext.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d6b9531..3f44b53 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,6 +117,13 @@ dnl check for support for Solaris Trusted Extensions
AC_CHECK_HEADERS([tsol/label.h])
AC_CHECK_FUNCS([is_system_labeled])
+dnl check for IOV_MAX, and fall back to UIO_MAXIOV on BSDish systems
+AC_CHECK_DECL([IOV_MAX], [],
+ [AC_CHECK_DECL([UIO_MAXIOV], [AC_DEFINE([IOV_MAX], [UIO_MAXIOV])],
+ [AC_DEFINE([IOV_MAX], [16], [Define if not provided by <limits.h>])],
+ [[#include <sys/uio.h>]])],
+ [[#include <limits.h>]])
+
xcbincludedir='${includedir}/xcb'
AC_SUBST(xcbincludedir)