summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2011-12-01 16:24:12 -0500
committerKeith Packard <keithp@keithp.com>2011-12-02 09:07:40 +0000
commitfd976e4051e15ab2d01ec0bf89ff26926d4ed04e (patch)
tree99dd2ff6b32177dc958814c8072b9312cdd9ab18 /configure.ac
parentfb22a408c69a84f81905147de9e82cf66ffb6eb2 (diff)
config: conftest needs an include directive to locate X11/Xfuncproto.h
The compiler option -fvisibility=hidden is erroneously missing due to a faulty configuration test. The gcc command is unable to locate X11/Xfuncproto.h unless the build occurs on a system where X11 development headers are installed. configure:21294: checking for symbol visibility support configure:21323: gcc -std=gnu99 -c -g -O2 -fvisibility=hidden conftest.c >&5 conftest.c:144:28: fatal error: X11/Xfuncproto.h: No such file or directory The solution is to add an include directive to obtain the location of X11/Xfuncproto.h which may or may not be the system installed headers. Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com> Signed-off-by: Gaetan Nadon <memsize@videotron.ca> Signed-off-by: Keith Packard <keithp@keithp.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e4fcba4a5..3d5414f4c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1558,7 +1558,8 @@ if test "x$XORG" = xyes; then
fi
if test x$have_visibility != xno; then
save_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS $VISIBILITY_CFLAGS"
+ proto_inc=`$PKG_CONFIG --cflags xproto`
+ CFLAGS="$CFLAGS $VISIBILITY_CFLAGS $proto_inc"
AC_TRY_COMPILE(
[#include <X11/Xfuncproto.h>
extern _X_HIDDEN int hidden_int;