summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCorentin Chary <corentin.chary@gmail.com>2011-06-06 16:36:28 +0200
committerKristian Høgsberg <krh@bitplanet.net>2012-03-27 09:31:55 -0400
commit7ea71227ac87804b6f200a8569f2dd8728c77e2f (patch)
tree29c64483a5b8251ba1eea6baf90b914b40359796 /configure.ac
parentde831a0244bb00c7849462289cc3cef504c012a7 (diff)
s/hosted/xwayland/
Signed-off-by: Corentin Chary <corentin.chary@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 3a817ac81..8c16a32b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -990,12 +990,12 @@ if test "x$COMPOSITE" = xyes; then
COMPOSITE_INC='-I$(top_srcdir)/composite'
fi
-HOSTED=yes
-AM_CONDITIONAL(HOSTED, [test "x$HOSTED" = xyes])
-if test "x$HOSTED" = xyes; then
- AC_DEFINE(XORG_HOSTED, 1, [Support hosted mode])
+WAYLAND=yes
+AM_CONDITIONAL(WAYLAND, [test "x$WAYLAND" = xyes])
+if test "x$WAYLAND" = xyes; then
+ AC_DEFINE(XORG_WAYLAND, 1, [Support wayland mode])
REQUIRED_MODULES="$REQUIRED_MODULES wayland-client"
- WAYLAND_SCANNER_RULES(['$(top_srcdir)/hw/xfree86/hosted'])
+ WAYLAND_SCANNER_RULES(['$(top_srcdir)/hw/xfree86/xwayland'])
fi
AM_CONDITIONAL(MITSHM, [test "x$MITSHM" = xyes])
@@ -1091,7 +1091,7 @@ case "$DRI2,$HAVE_DRI2PROTO" in
esac
AM_CONDITIONAL(DRI2, test "x$DRI2" = xyes)
-if test "x$DRI" = xyes || test "x$DRI2" = xyes || test "x$HOSTED" = xyes || test "x$DRM" = xyes; then
+if test "x$DRI" = xyes || test "x$DRI2" = xyes || test "x$WAYLAND" = xyes || test "x$DRM" = xyes; then
if test "x$DRM" = xyes; then
AC_DEFINE(WITH_LIBDRM, 1, [Building with libdrm support])
PKG_CHECK_MODULES([LIBDRM], $LIBDRM)
@@ -2178,7 +2178,7 @@ hw/xfree86/dixmods/extmod/Makefile
hw/xfree86/doc/Makefile
hw/xfree86/dri/Makefile
hw/xfree86/dri2/Makefile
-hw/xfree86/hosted/Makefile
+hw/xfree86/xwayland/Makefile
hw/xfree86/exa/Makefile
hw/xfree86/exa/man/Makefile
hw/xfree86/fbdevhw/Makefile