summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGuido Günther <agx@sigxcpu.org>2018-08-26 22:24:00 +0200
committerDylan Baker <dylan@pnwbakers.com>2018-08-27 11:32:04 -0700
commit9de34b4ddecb41deae8a4a6349534f330ce0f4cd (patch)
tree4f22bdc136362ef9085ef4bdc737b0e0d6ffec69 /meson.build
parent05e2fc6860c515073a5cd7ed305dae86fc9c8232 (diff)
meson: Don't enable any vulkan drivers on arm, aarch64
There's no Vulkan support for arm atm. Signed-off-by: Guido Günther <guido.gunther@puri.sm> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index c3a7e8cdd74..7f6f128e0b2 100644
--- a/meson.build
+++ b/meson.build
@@ -179,6 +179,8 @@ if _vulkan_drivers.contains('auto')
if system_has_kms_drm
if host_machine.cpu_family().startswith('x86')
_vulkan_drivers = ['amd', 'intel']
+ elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
+ _vulkan_drivers = []
else
error('Unknown architecture @0@. Please pass -Dvulkan-drivers to set driver options. Patches gladly accepted to fix this.'.format(
host_machine.cpu_family()))